Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX II and MAX

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old September 10th, 2015
timroswell timroswell is offline
Junior Member
 
Join Date: Mar 2014
Posts: 10
Default Problem with new Passport Max2

I purchased a new Max2 from Amazon over the weekend. I currently also have a Max. Just got tired of switching between the cars so bought a Max2.
I registered the Max2 on Escort's website.

However when I connected the Max2 to PC running Windows 7 and another running 10, connected but showed serial nbr as all zeros, I could click the update button, unit updated but merged button was grayed out. Attached picture.

Escort customer support told me for new units you get a free database subscription for a certain nbr of days, that shouldnt be an issue???

Tried my MAX on both machines, worked perfectly.

Called customer support, they told me issue was with Windows 10. Told them tried on windows 7/10 same problem. Max detector all worked fine. Told me to uninstall detector tools/reinstall did that, was same version 1.11.60. Still same results.

Called again, they told me the problem was with detector tools, was being fixed, try again tonight. ok, uninstalled tools, reinstalled tools, same version, same problem. Max OK, MAX 2 no serial nbr.

Also checked in Windows 7/10 Control Panel/Devices when either unit connected shows just Passport Max for both. I thought it might show Passport Max 2

Bottom line, everything works fine with old Max, but not with new Max 2.

Not even sure if Max2 is even working, drove around awhile, went by all the usual spots, nothing. Also followed police car thinking it might pick something up, nothing. But then again in my suburb, Roswell outside of Atlanta, i think they only use laser guns. That's all I ever seem to pickup in the 2 usual spots.

Any suggestions? Any advice? Is there a way to escalate with customer support?
Reply With Quote
  #2  
Old September 10th, 2015
V0rtex's Avatar
V0rtex V0rtex is offline
Senior Member
 
Join Date: Jul 2013
Posts: 844
Default

I don't know about the Max issue, but I remember walking up to a Roswell police car parked in a Chick-fil-a (the one near Startime) to see what radar gun they were using so it's not all laser there.
Reply With Quote
  #3  
Old September 10th, 2015
timroswell timroswell is offline
Junior Member
 
Join Date: Mar 2014
Posts: 10
Default Roswell Laser Guns

I normally see them on Crossville Road before where it turns into Woodstock & before Crabapple. Also they hide out on Houze Road, in the residential area where it starts a Chaffin Road spot
Its my understanding in GA, the police departments need to register with the state spots that they use. Kinda makes since, cause I only ever see them in the same spots over and over again. But never able to confirm it or find a list.
If you get a speeding ticket in DeKalb, its expensive but they don't seem to report them DMV, I had 2 - I drive a Porsche but when I checked my DMV record neither was there. And they both were over 2 years old. Such a corrupt county anyways
Reply With Quote
  #4  
Old September 10th, 2015
smokinu454's Avatar
smokinu454 smokinu454 is offline
Senior Member
 
Join Date: Aug 2013
Location: The Bluegrass State
Posts: 1,258
Default

Quote:
Originally Posted by timroswell View Post
I purchased a new Max2 from Amazon over the weekend. I currently also have a Max. Just got tired of switching between the cars so bought a Max2.
I registered the Max2 on Escort's website.

However when I connected the Max2 to PC running Windows 7 and another running 10, connected but showed serial nbr as all zeros, I could click the update button, unit updated but merged button was grayed out. Attached picture.

Escort customer support told me for new units you get a free database subscription for a certain nbr of days, that shouldnt be an issue???

Tried my MAX on both machines, worked perfectly.

Called customer support, they told me issue was with Windows 10. Told them tried on windows 7/10 same problem. Max detector all worked fine. Told me to uninstall detector tools/reinstall did that, was same version 1.11.60. Still same results.

Called again, they told me the problem was with detector tools, was being fixed, try again tonight. ok, uninstalled tools, reinstalled tools, same version, same problem. Max OK, MAX 2 no serial nbr.

Also checked in Windows 7/10 Control Panel/Devices when either unit connected shows just Passport Max for both. I thought it might show Passport Max 2

Bottom line, everything works fine with old Max, but not with new Max 2.

Not even sure if Max2 is even working, drove around awhile, went by all the usual spots, nothing. Also followed police car thinking it might pick something up, nothing. But then again in my suburb, Roswell outside of Atlanta, i think they only use laser guns. That's all I ever seem to pickup in the 2 usual spots.

Any suggestions? Any advice? Is there a way to escalate with customer support?
Did you register your serial number online before trying to update?
__________________
RL360C+ZW5
max 3
Reply With Quote
  #5  
Old September 10th, 2015
timroswell timroswell is offline
Junior Member
 
Join Date: Mar 2014
Posts: 10
Default

Actually no, it's not a required field. Customer support says it's not required, the software picks it up. But then again haven't had much luck with customer support eith.
Sounds like yet another call.
Reply With Quote
  #6  
Old September 10th, 2015
timroswell timroswell is offline
Junior Member
 
Join Date: Mar 2014
Posts: 10
Default

All
I have opted to return the unit to Amazon indicating defective and replace the unit. Hopefully better luck with this one. I'm getting one day shipping, will be here tomorrow. Hopefully better luck with a new one.
Escort wanted me to ship it to them, they'd figure out what the problem is and fix but would take 6-8 business days. Considering the cost of it and it was brand new, I want a new one, not fix the current one.
Reply With Quote
  #7  
Old September 10th, 2015
leesrt leesrt is offline
Banned
 
Join Date: Feb 2015
Location: Florida
Posts: 737
Default

Quote:
Originally Posted by timroswell View Post
All
I have opted to return the unit to Amazon indicating defective and replace the unit. Hopefully better luck with this one. I'm getting one day shipping, will be here tomorrow. Hopefully better luck with a new one.
Escort wanted me to ship it to them, they'd figure out what the problem is and fix but would take 6-8 business days. Considering the cost of it and it was brand new, I want a new one, not fix the current one.
Good call.
Reply With Quote
  #8  
Old September 11th, 2015
timroswell timroswell is offline
Junior Member
 
Join Date: Mar 2014
Posts: 10
Smile Returned passport max2

All
Returned Passport Max 2 back to Amazon.com. Received new one today, Detector fount it, displayed serial nbr. Good to go
Reply With Quote
Reply

Tags
detector tools, max, max2

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:06 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.