Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX II and MAX

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 18th, 2018
marcuswelbymd1 marcuswelbymd1 is offline
Junior Member
 
Join Date: Jul 2015
Posts: 25
Default Bluetooth connection - must reset each time

Hello,

Anyone else have to constantly remove and then re-add Passport 2 to their iOS Bluetooth menu?

I have the new Smart Cord (no USB port). Presumably since the latest iOS update, my Bluetooth from my iPhone no longer automatically pairs with my Max2. My phone Settings shows there is a Bluetooth connection with Passport 2, however the App shows the Red "no Bluetooth" symbol, and in the App Settings, it shows no Bluetooth connection. My detector shows no Bluetooth connection as well.

Instead, each time I start my car I must go into phone Settings, choose Passport 2, choose "Forget my Device", turn off Bluetooth, turn it on, then search for Devices, then re-pair my Passport 2 Bluetooth connection.

After going through this sequence, my App will show a blue Bluetooth symbol, App Settings shows the "Passport 2" label, and my detector shows the blue Bluetooth symbol.

It's a giant pain and unsafe while driving to do all this.

Thanks for your help and advice!
Reply With Quote
  #2  
Old January 18th, 2018
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,916
Default

Quote:
Originally Posted by marcuswelbymd1 View Post
Hello,

Anyone else have to constantly remove and then re-add Passport 2 to their iOS Bluetooth menu?

I have the new Smart Cord (no USB port). Presumably since the latest iOS update, my Bluetooth from my iPhone no longer automatically pairs with my Max2. My phone Settings shows there is a Bluetooth connection with Passport 2, however the App shows the Red "no Bluetooth" symbol, and in the App Settings, it shows no Bluetooth connection. My detector shows no Bluetooth connection as well.

Instead, each time I start my car I must go into phone Settings, choose Passport 2, choose "Forget my Device", turn off Bluetooth, turn it on, then search for Devices, then re-pair my Passport 2 Bluetooth connection.

After going through this sequence, my App will show a blue Bluetooth symbol, App Settings shows the "Passport 2" label, and my detector shows the blue Bluetooth symbol.

It's a giant pain and unsafe while driving to do all this.

Thanks for your help and advice!
It would help to know which model iPhone you are using, and which iOS version. Additionally, what are the two first digits of your detector's serial number?

The devil is in the details...
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
Dashcam: Escort M1 and Thinkware F750

-------------------------------------
Moderators here are not Escort employees.

If you need immediate help, please call Escort Radar customer service right after they open at 9:00 A.M. Eastern time, at 1-800-543-1608, option 2. Wait for the pause following the message and use the option for a call-back.
-------------------------------------
Reply With Quote
  #3  
Old January 18th, 2018
marcuswelbymd1 marcuswelbymd1 is offline
Junior Member
 
Join Date: Jul 2015
Posts: 25
Default

Hi,

Serial number first 2 digits: 67
iPhone 6Plus
iOS 11.2

Thanks!
Reply With Quote
  #4  
Old January 19th, 2018
andreww88 andreww88 is offline
Member
 
Join Date: Mar 2017
Location: Mobile, AL
Posts: 54
Default

Quote:
Originally Posted by marcuswelbymd1 View Post
Hi,

Serial number first 2 digits: 67
iPhone 6Plus
iOS 11.2

Thanks!
Did you update the radar detector recently to the latest version? There was a problem with this bluetooth connectivity but it has been fixed in the firmware of the radar detector.
Reply With Quote
  #5  
Old January 19th, 2018
marcuswelbymd1 marcuswelbymd1 is offline
Junior Member
 
Join Date: Jul 2015
Posts: 25
Default

Thanks for the advice, still haven't been able to fix it.

Had 2 free hours this morning. Updated my firmware on my Max 2 (failed 6 times, 7th time it worked. However before updating, the firmware said it had been updated Jan.3, 2018 (the last time I tried this), so I don't think this will make a difference).

I have updated my phone to iOS 11.2.2

I have deleted and reinstalled the Escort Live App.

Despite all this, my phone Settings says Passport2 Bluetooth is connected, but my detector doesn't give me the Bluetooth symbol, nor does my App show Bluetooth is connected (it says it cannot find a device in Settings).

I still have to choose "Forget my Device", turn Bluetooth on/off, turn detector on/off, re-pair Passport2 with my phone each time.

Slightly frustrating...

Cheers.
Reply With Quote
  #6  
Old May 28th, 2018
crouthmr crouthmr is offline
Junior Member
 
Join Date: May 2018
Posts: 1
Default

Same exact issue here.
Reply With Quote
  #7  
Old May 29th, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 17,082
Default

Update your detector using the latest version of Detector Tools for Windows and select "Update All" in the Advanced tab.

After the update, you will need to pair the detector to your iPhone again.
__________________

Escort Radar customer service is available from 9am-5:00pm Eastern Time Mon-Fri at 1-800-543-1608 or you can fill out a repair form and we will contact you.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:34 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.