View Single Post
  #4  
Old August 30th, 2021
DJ23 DJ23 is offline
Junior Member
 
Join Date: Mar 2012
Posts: 19
Default

Quote:
Originally Posted by EscortRadar View Post
Escort Laser Shifter firmware update V2.12 & V1.12 (Version 2 and Version 1 laser shifters) Release Notes

What’s New in Firmware v2.12 & V1.12
Cedar Electronics is happy to announce the release of version 2.12 and version 1.12 firmware for its laser shifters. We have several minor improvements which have been made in this release which should continue to improve your experience with our laser shifters. This firmware update applies to:
• Max Ci 360
• Max Ci
• iXCi
• Max Ci Platform (relevant if shifters connected)
• Max Ci International (relevant if shifters connected)
• ZR5
• ZW5

Enhancements:
• Improved performance rear laser shifters (ports 3 & 4)
• Fixed a laser gun identification bug
• Improved overall jamming performance

How to tell the difference between version 2 and version 1 shifters
The version 1 shifters and bridge box were changed in the fall of 2018 due to an end of life component. The performance is the same as version 2. Version 2 shifters have a white stripe on the cable near the connector tip for the bridge box. Version 2 Bridge boxes have a white dot on the bottom. Your installer will be able to look at your install to determine which version you currently have.

How to Get the Update
For consumers, take your vehicle to an authorized Escort custom install installer. For installers, you can find the update on Detector Tools pro (https://www.escortradar.com/pages/update-your-device). There are two different links on the page depending on if you are using Windows or Mac OS.

Keep the Feedback Coming
We want to keep hearing from you! If you have feedback or suggestions on how to make the Redline 360c even better, send an email to radarfeedback@cedarelectronics.com.
Question; I have downloaded the updated Detector Tools. I can update my Defender Data Base, but I get a "Stack Trace" Error when trying to upgrade the Firmware. Anything I need to do differently? Of is there something I'm doing wrong. The first was trying to re-load Detector Tools. This did not help.

Thanks, Jay
Reply With Quote