Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Passport 9500ix, S75G

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #21  
Old December 31st, 2011
giguy giguy is offline
Junior Member
 
Join Date: Dec 2011
Posts: 6
Default

Quote:
Originally Posted by Minoclan View Post
I have spent 3 hours trying to get any computer to recognize my new 9500ix. None of the suggestions worked.
Does your 9500ix at least power on while connecting the usb data port to your computer?
Reply With Quote
  #22  
Old December 31st, 2011
anim8rjb anim8rjb is offline
Junior Member
 
Join Date: Nov 2010
Posts: 11
Default

If its not going into USB mode when you connect it, you can force it I to USB mode by holding the two right-most buttons down when you power it up. I can't remember off-hand what the buttons are..I think MRK and BRT? Either way, it's the top and bottom buttons on the right, if you're looking at the unit from above. You just hold those buttons down while the unit powers up, and release them when the display reads 'USB'.

Last edited by anim8rjb; December 31st, 2011 at 10:06 PM.
Reply With Quote
  #23  
Old January 1st, 2012
Minoclan Minoclan is offline
Junior Member
 
Join Date: Dec 2011
Posts: 15
Default

Quote:
Originally Posted by anim8rjb View Post
If its not going into USB mode when you connect it, you can force it I to USB mode by holding the two right-most buttons down when you power it up. I can't remember off-hand what the buttons are..I think MRK and BRT? Either way, it's the top and bottom buttons on the right, if you're looking at the unit from above. You just hold those buttons down while the unit powers up, and release them when the display reads 'USB'.
Thanks for the advice but I did that 3 times.
Reply With Quote
  #24  
Old January 1st, 2012
Minoclan Minoclan is offline
Junior Member
 
Join Date: Dec 2011
Posts: 15
Unhappy

I just went to Best Buy and got a replacement unit. The one I bought yesterday was defective. I come home all psyched and the website is down. Is this the way it is going to be?
Reply With Quote
  #25  
Old January 1st, 2012
Ianaber's Avatar
Ianaber Ianaber is offline
Senior Member
 
Join Date: Apr 2011
Location: Wet Coast...
Posts: 417
Default

I've found with my 9500IX (serial starts with 22), that if the unit was powered down when I removed it from one of my vehicles, and I plug it into my laptop for updating, I have to press the power button to get the USB indication to come up. If I just disconnected the power cord and didn't power it down, it lights up the USB without pressing the power button when connected.
Reply With Quote
  #26  
Old January 3rd, 2012
charger368's Avatar
charger368 charger368 is offline
Member
 
Join Date: Dec 2011
Location: Illinois (St. Louis Area)
Posts: 34
Angry 9500ix not being recognized

I am also experiencing the "No Detector Connected" - I can not get the Escort Detector Tools to recognize the 9500ix. It is new (a few weeks old, serial number 3500XXXX - Racing Edition).

The first time I connected it I had no problems updating it. Tonight (my second time connecting it to the Escort software) it was is just invisible to the PC and Detector Tools. I've tried everything that has been suggested in this thread and have had no luck. Tried all the drivers (the 3 of them), tried the repair Detector Tools reinstall, tried the leave powered on when unplugging from car, tried powering it up via power adapter (serial number 35 is supposed to connect with USB power only), tried the PS3 USB and even tried the MRK BRT forced USB and no luck.

I'm at 4 hours of frustration (about 3 hours and 40 minutes of excessive frustration) and decided to stop trying to get it connected.

Any ideas on next steps????????????
Reply With Quote
  #27  
Old January 4th, 2012
giguy giguy is offline
Junior Member
 
Join Date: Dec 2011
Posts: 6
Default

Quote:
Originally Posted by charger368 View Post
I am also experiencing the "No Detector Connected" - I can not get the Escort Detector Tools to recognize the 9500ix. It is new (a few weeks old, serial number 3500XXXX - Racing Edition).

The first time I connected it I had no problems updating it. Tonight (my second time connecting it to the Escort software) it was is just invisible to the PC and Detector Tools. I've tried everything that has been suggested in this thread and have had no luck. Tried all the drivers (the 3 of them), tried the repair Detector Tools reinstall, tried the leave powered on when unplugging from car, tried powering it up via power adapter (serial number 35 is supposed to connect with USB power only), tried the PS3 USB and even tried the MRK BRT forced USB and no luck.

I'm at 4 hours of frustration (about 3 hours and 40 minutes of excessive frustration) and decided to stop trying to get it connected.

Any ideas on next steps????????????
I am in the same boat. The last 4 digits after my serail# are 5011 (If my interpretation is correct it was built recently 50th week of 2011)

Does your 9500 even turn on with the usb connected to the computer?
I can't even get it to power up.
Reply With Quote
  #28  
Old January 4th, 2012
charger368's Avatar
charger368 charger368 is offline
Member
 
Join Date: Dec 2011
Location: Illinois (St. Louis Area)
Posts: 34
Default

Quote:
Originally Posted by giguy View Post
I am in the same boat. The last 4 digits after my serail# are 5011 (If my interpretation is correct it was built recently 50th week of 2011)

Does your 9500 even turn on with the usb connected to the computer?
I can't even get it to power up.

It only powers up (usb connected) if I also connect to external power - 9 volt adapter power, but still no communication. If I'm correct, units with serial numbers starting with 33 or above should not require external power to connect and communicate. The first and only time it communicated I did not have external power applied (the unit did not wake - stayed dark when usb connected) and it updated.

This morning I again tried using Windows 7 and then another computer with XP and still no luck, I believe "What We Have Here Is A Failure To Communicate!"

I'm going to call Escort today to see what they say about this problem. A new unit two weeks old should not be experiencing problems like this.

I'm not sure about the last 4 digits you mentioned about representing the date. If so mine would have been made the 22nd week of 2022. Thanks for your reply. If I find out anything from Escort I'll post it.
Reply With Quote
  #29  
Old January 4th, 2012
wayneo wayneo is offline
Junior Member
 
Join Date: Jan 2012
Posts: 1
Default USB Port

I think that the USB port is the weak point of the 9500ix detector. Three days ago I bought a 9500ix from Best Buy, got it home, plugged in the cord and nothing. Absolutely nothing. The 12V worked fine just no USB connectivity. Called tech support and after trying a few things that were recommended to me by tech support I took the unit back to Best Buy. The new unit then worked perfectly. It's a great detector with a weak spot.. HAPPY NEW YEAR to ALL
Reply With Quote
  #30  
Old January 4th, 2012
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,951
Default

Quote:
Originally Posted by giguy View Post
I am in the same boat. The last 4 digits after my serail# are 5011 (If my interpretation is correct it was built recently 50th week of 2011)

Does your 9500 even turn on with the usb connected to the computer?
I can't even get it to power up.
The USB connection will not power the detector fully. It will only put it in USB mode with "USB" on the detector's display.

If you plug in the USB cord and do not see USB on the display then press the power button. If you still do not see USB try a different USB port directly on your computer. Still no USB? Then contact us, it may need serviced.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or you can fill out a repair form and we will contact you.
Reply With Quote
Reply

Tags
9500ix, detector tools, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:09 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.