Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old September 7th, 2017
Avnyc11 Avnyc11 is offline
Member
 
Join Date: Jan 2016
Posts: 89
Default Scary encounter / I think my detector needs service

I was driving over a bridge in NYC where I've only ever seen KA used and I was on the straight part of the bridge. Thankfully I knew there was a speed trap at the end of the straight so I slowed down, because as I drove by, there was a LEO with radar in hand and my max 360 didn't alert me.

If it was I/O then there were enough speeding cars that my max should have gone off.
Now the LEO may have not been firing but then why would he be in firing stance wth radar pointed at oncoming cars?

I got a KA false about a mile earlier so I thought everything was working fine but now I'm not sure. I think my max may need service.
__________________
Countermeasures: Max 360 + VEiL G5 + Waze
Reply With Quote
  #2  
Old September 7th, 2017
yellowtang yellowtang is offline
Banned
 
Join Date: Dec 2014
Posts: 350
Default

Quote:
Originally Posted by Avnyc11 View Post
I was driving over a bridge in NYC where I've only ever seen KA used and I was on the straight part of the bridge. Thankfully I knew there was a speed trap at the end of the straight so I slowed down, because as I drove by, there was a LEO with radar in hand and my max 360 didn't alert me.

If it was I/O then there were enough speeding cars that my max should have gone off.
Now the LEO may have not been firing but then why would he be in firing stance wth radar pointed at oncoming cars?

I got a KA false about a mile earlier so I thought everything was working fine but now I'm not sure. I think my max may need service.
Are you sure he was not holding a laser unit?

What firmware are you running?
Reply With Quote
  #3  
Old September 7th, 2017
Avnyc11 Avnyc11 is offline
Member
 
Join Date: Jan 2016
Posts: 89
Default

1.6 on the old 79 detector. Don't think it's laser because the 360 didn't alert for laser either for any of the cars around me but I'll monitor over the next few days to see if I get a laser alert here
__________________
Countermeasures: Max 360 + VEiL G5 + Waze
Reply With Quote
  #4  
Old September 7th, 2017
yellowtang yellowtang is offline
Banned
 
Join Date: Dec 2014
Posts: 350
Default

Quote:
Originally Posted by Avnyc11 View Post
1.6 on the old 79 detector. Don't think it's laser because the 360 didn't alert for laser either for any of the cars around me but I'll monitor over the next few days to see if I get a laser alert here
Some people, myself included, have been experiences issues and odd behavior with the new v1.6 firmware, more so on K-band though.

Although I had a really badly delayed c/o ka encounter the other day from the front.

Prior i had a great rear ka alert with no leo in view.

My k-band did not alert at all the other day until i restarted my M360 - Escort gave me what couple be a possible reason for it based on the new filter, but i question it as it has yet to do it since again.

if you notice anything else please let us know.
Reply With Quote
  #5  
Old September 8th, 2017
Avnyc11 Avnyc11 is offline
Member
 
Join Date: Jan 2016
Posts: 89
Default

I've noticed strange behavior too since installing 1.6

I'll keep monitoring in my daily commute and report back
__________________
Countermeasures: Max 360 + VEiL G5 + Waze
Reply With Quote
  #6  
Old September 8th, 2017
Butcher318 Butcher318 is offline
Armchair Expert
 
Join Date: Dec 2011
Location: Indiana
Posts: 2,040
Default

Quote:
Originally Posted by Avnyc11 View Post
I was driving over a bridge in NYC where I've only ever seen KA used and I was on the straight part of the bridge. Thankfully I knew there was a speed trap at the end of the straight so I slowed down, because as I drove by, there was a LEO with radar in hand and my max 360 didn't alert me.

If it was I/O then there were enough speeding cars that my max should have gone off.
Now the LEO may have not been firing but then why would he be in firing stance wth radar pointed at oncoming cars?

I got a KA false about a mile earlier so I thought everything was working fine but now I'm not sure. I think my max may need service.

If he was in a "fireing stance" holding the unit up to his face then that is LASER. Laser must be aimed like that. If your that close or he shoots you in the rear a detector won't catch it. The beam is too narrow.
Reply With Quote
  #7  
Old September 8th, 2017
Avnyc11 Avnyc11 is offline
Member
 
Join Date: Jan 2016
Posts: 89
Default

I'm not sure what's worse, my detector being broken or laser in my area.

I encountered a speed sign today and I only got 0.4 mile warning on K like others have been reporting with 1.6
__________________
Countermeasures: Max 360 + VEiL G5 + Waze
Reply With Quote
  #8  
Old September 13th, 2017
Bestia Bestia is offline
Junior Member
 
Join Date: Aug 2017
Posts: 10
Default

Quote:
Originally Posted by Avnyc11 View Post
I was driving over a bridge in NYC where I've only ever seen KA used and I was on the straight part of the bridge. Thankfully I knew there was a speed trap at the end of the straight so I slowed down, because as I drove by, there was a LEO with radar in hand and my max 360 didn't alert me.

If it was I/O then there were enough speeding cars that my max should have gone off.
Now the LEO may have not been firing but then why would he be in firing stance wth radar pointed at oncoming cars?

I got a KA false about a mile earlier so I thought everything was working fine but now I'm not sure. I think my max may need service.
I have had that issue on more than one occasion. Please see my post. Calling Escort tomorrow to see if it can be resolved.

http://escortradarforum.com/forums/s...ad.php?t=16451
Reply With Quote
  #9  
Old September 13th, 2017
Butcher318 Butcher318 is offline
Armchair Expert
 
Join Date: Dec 2011
Location: Indiana
Posts: 2,040
Default

Each encounter is different, there are many variables. You guysxwill just have to watch your detector and see how it performs over several weeks with numerous encounters.

If it was radar on the bridge if the officer judged no one was speeding he could have stayed in hold mode for quite some time. Many officers now do this to minimize their transmit time. The next time you drive over that bridge it could be a different officer who is trigger happy. If it was a handheld unit don't forget, he can shoot both direction easily. He can also wait until you pass and shoot you in tbe back. All these thing will drastically effect detection range.
Reply With Quote
  #10  
Old September 15th, 2017
dsprockeee1 dsprockeee1 is offline
Member
 
Join Date: Mar 2017
Posts: 39
Default

Quote:
Originally Posted by Butcher318 View Post
Each encounter is different, there are many variables. You guysxwill just have to watch your detector and see how it performs over several weeks with numerous encounters.

If it was radar on the bridge if the officer judged no one was speeding he could have stayed in hold mode for quite some time. Many officers now do this to minimize their transmit time. The next time you drive over that bridge it could be a different officer who is trigger happy. If it was a handheld unit don't forget, he can shoot both direction easily. He can also wait until you pass and shoot you in tbe back. All these thing will drastically effect detection range.
Completely understandable. But when it seems the vast majority of users who updated to 1.6, started noticing problems all around the same time frame, it's not just coincidence. Some people are reporting no problems at all but it could just be they haven't had any encounters with LEOs yet. I mean I can go for a week without seeing a LEO on my way to work, and then randomly one day pick one up near a speed trap location. The same could be applying to the users who say they aren't having problems, because they haven't had any real encounters yet.
Reply With Quote
Reply

Tags
alerts not working, ka band, max 360, service

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:20 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.