Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Passport 9500ix, S75G

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #41  
Old May 13th, 2012
Rdaufan Rdaufan is offline
Junior Member
 
Join Date: Feb 2011
Posts: 8
Default Add me to the list...

Just purchased the 9500 today. Downloaded the tools and connected via USB. Worked fine and then connected again and detector now cannot be detected. Tried the solutions suggested here and none working. Really disappointed that within days of purchasing it, it looks like I will have to send it in for servicing. Serial number starts with 33. I'll call Escort tomorrow and see what they say.
Reply With Quote
  #42  
Old August 4th, 2013
ermagerd ermagerd is offline
Junior Member
 
Join Date: Aug 2013
Location: MD
Posts: 1
Default

I'm having this same issue as well with a 22xxx detector. I know it's been a long time, but it's been sitting in a box for the last 2 years while I was out of the country.

Update: I was using a brand new usb to mini from walmart, and the detector wasn't showing up in detector tools. I got upset and dug out a really old cable from a box in the garage. Wouldn't you know, it installed and worked with detector tools. Strange. Maybe trying multiple cords will help some people having issues.

Last edited by ermagerd; August 4th, 2013 at 09:01 PM.
Reply With Quote
  #43  
Old August 5th, 2013
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,957
Default

Some USB cords are for charging only, not for data transfer. Our detectors require a data transfer cable.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or you can fill out a repair form and we will contact you.
Reply With Quote
  #44  
Old August 6th, 2013
fiberrich's Avatar
fiberrich fiberrich is offline
Senior Member
 
Join Date: Apr 2012
Location: Out Chasing Wabbits!
Posts: 974
Default

Quote:
Originally Posted by EscortRadar View Post
Some USB cords are for charging only, not for data transfer. Our detectors require a data transfer cable.
I don't know why Escort just can't include a USB cable in the box with their $500+ upgradeable USB detectors.
Reply With Quote
  #45  
Old August 15th, 2013
Insolent Minx Insolent Minx is offline
Junior Member
 
Join Date: Aug 2013
Location: Tomball, Texas
Posts: 6
Default 9500ix bugged out

I had the same exact problem as everyone else. The detector software could not find the device or it could not find the serial number. Then it would not even power up. It would just click when I plugged it into the cigarette lighter. Frustrated, I looked on the forum and found instructions that said to hold down both the BRK and MRK buttons and plug the power in at the same time. I did that and the USB lit up on the screen. Then I let go of the buttons and plugged the mini-usb cable in and started up the detector software. The instructions told me that the software update had not finished correctly and to update the software before you do anything. I did that and it worked all the way to 100%. After that I went to the database synchro and did that and it worked to 100%. I think I may have fixed the damn thing after all!

IM
Reply With Quote
  #46  
Old August 17th, 2013
Slow35th Slow35th is offline
Junior Member
 
Join Date: May 2012
Posts: 24
Default

Same issue for me. I actually have three 9500ix's. I just bought a new one because one just completely died. I went to update the other one and it can not be seen by any computer. It will go into USB mode by holding down the Bright and Mark buttons but will not talk to the computer when I plug in the USB cable. I guess I will be sending the dead one and the one with the bad USB port in for service. Since this USB issue seems to be so common, is this an issue that gets fixed at no charge? Sure seems like a flaw to me.
Reply With Quote
  #47  
Old August 22nd, 2013
HPNO300 HPNO300 is offline
Junior Member
 
Join Date: Mar 2013
Location: North TX
Posts: 1
Default

As mentioned several times already, I have been able to update my 9500ix race edition several times before until today. Serial number starts with 35 and I have tried every single possible trouble shooting steps possible. It seems to be a pretty common issue on these units. I really don't have the time to send back and wait several weeks to receive my unit and would rather fix it myself if someone is able to provide me with the correct steps that I need to take in order to fix this issue myself.
Reply With Quote
Reply

Tags
9500ix, detector tools, usb

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 01:22 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.