Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Passport 8500, X50, X50 Black

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old September 25th, 2011
punkNdrublic04 punkNdrublic04 is offline
Junior Member
 
Join Date: Sep 2011
Posts: 5
Unhappy Brand new x50 black - defective??

Hey everyone,

I just bought a brand new x50 black straight from Escort last week. After driving around the past few days I'm beginning to think its defective?? Every time I encounter a LEO who is either moving or stationary I get almost NO warning. The x50 goes off either k or ka with 3 or 4 signal bars. I haven't once see it do a ramp up from 1-full signal bars, it always starts at 3 or 4 and goes all the way up a few seconds later and then drops to 4 or 5 and then full again. It doesn't matter if I am on a perfectly flat road or coming around a slight corner or going up/down a slight hill. I also tired the detector in another car with the same results.

Also when coming to a few red lights in a different town I will all of a sudden get a full x band (in city mode) as soon as I'm maybe 200-300 feet from the red light and after I pass it the signal bars will progressively get lower and lower. I turned around at one light thinking maybe it was directional or something but I get the same results going the other way. Its almost like the front sensors are not working properly??

I have tried resetting the unit 3 times and I am constantly getting false x band alerts, and occasional false k and ka band alerts when in city mode.

I haven't owned a radar detector in a few years, but I almost feel like my $100 Cobra detector from 4 years ago had better range, which is really leading me to believe mine is defective. Tomorrow night I am going with my buddy who has a silver x50 and we are going to test his against mine in an area with some speed signs, but we know not to run them next to each other at the same time.

If anyone has any thoughts on this please let me know.

Thank you, and sorry for the novel of a post lol.
Reply With Quote
  #2  
Old September 25th, 2011
punkNdrublic04 punkNdrublic04 is offline
Junior Member
 
Join Date: Sep 2011
Posts: 5
Default

Just an update. I was just driving on the highway in highway mode and came up on a "drone", the signs in wheels that displays messages, and I did not get any alert until I was less then a 1/4 mile away and it alerted to full k band.

Is there any way for sure I can test to see if this thing is defective or not??

If anyone can help a somewhat "newbie" out that would be awesome.
Reply With Quote
  #3  
Old September 26th, 2011
KaPro KaPro is offline
Senior Member
 
Join Date: Jul 2009
Posts: 292
Default

Try doing a reset. That detection range indeed seems reduced. EscortRadar will answer you during the day Monday. To do a reset, with the unit off, hold the two buttons down on top of the unit and at the same time turn the unit on.
__________________
8500 X50 (S7)
STi A6M9 (M3)
Redline (M3)
Reply With Quote
  #4  
Old September 26th, 2011
punkNdrublic04 punkNdrublic04 is offline
Junior Member
 
Join Date: Sep 2011
Posts: 5
Default

Thanks fir the reply. I have done 3 resets, same method with holding the 3 buttons when turning it on.
Reply With Quote
  #5  
Old September 26th, 2011
punkNdrublic04 punkNdrublic04 is offline
Junior Member
 
Join Date: Sep 2011
Posts: 5
Default

Bump....No one has any ideas how I can try to diagnose this problem??
Reply With Quote
  #6  
Old September 26th, 2011
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,741
Default

Unless every police radar encounter that you have had is with their radar aimed away from you (called "forward facing") then your X50 Black definitely should be looked at.

Are the X band detections at the intersection from a nearby store's door opener? I'm not aware of any radar-based red light or speed cameras in existence.

Please contact us at the number in my signature below.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #7  
Old September 26th, 2011
punkNdrublic04 punkNdrublic04 is offline
Junior Member
 
Join Date: Sep 2011
Posts: 5
Default

I have had several encounters with LEO doing radar in the median of the highway directly facing me with the same results.

A few of the red lights I came to did have auto doors that could have effected it, but a few were in the middle of no where with nothing around.

Like I said in my original post, tonight me and my buddy are going to test my detector against his older x50 silver with some k band speed signs.

I will call customer service later tonight if our testing confirms that it is indeed defective.

Just out of curiosity, do you know what the process would be if this is defective?? Do I have to pay to ship it back for an exchange?? I also paid for overnight shipping when I bought it last week, would it be overnighted back to me after exchanged??
Reply With Quote
  #8  
Old September 27th, 2011
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,741
Default

If it was purchased from us within the 30 day refund period then we can replace the defective X50 and pay for all of the shipping involved. We normally do not offer next day shipping on the replacement or on the return label.

If this defective X50 is within the 30 day refund period and you want it as fast as possible then buy another X50 and return the defective one and we will refund the original X50 purchase.

Our phone reps can help you with whichever method you choose.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Tags
defective, false, range, signal, x50

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:43 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.