Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Detector Tools & Detector Tools Pro

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old June 11th, 2019
kconwell kconwell is offline
Junior Member
 
Join Date: Jun 2019
Posts: 2
Question Detector Tools Pro crashing on startup

I've been using the Detector Tools Pro software successfully to update my Max 360 for a while now. Today when I went to update my detector, I was greeted with the following error. I tried uninstalling the software and reinstalling and the error persists. Any ideas on how to fix it?
Attached Images
 
Reply With Quote
  #2  
Old June 12th, 2019
TommVee TommVee is offline
Junior Member
 
Join Date: May 2019
Posts: 1
Default I am having the same issue.

What needs to be done to get this to work?
Reply With Quote
  #3  
Old June 12th, 2019
thewalkingdr3ad thewalkingdr3ad is offline
Junior Member
 
Join Date: Jun 2019
Posts: 4
Default

same here with win 10 and confirmed data cable. tried both version and neither work. someone help me update my x80!
Reply With Quote
  #4  
Old June 12th, 2019
ThomThom ThomThom is offline
Senior Member
 
Join Date: Feb 2010
Location: Accokeek, MD
Posts: 233
Default

Quote:
Originally Posted by kconwell View Post
I've been using the Detector Tools Pro software successfully to update my Max 360 for a while now. Today when I went to update my detector, I was greeted with the following error. I tried uninstalling the software and reinstalling and the error persists. Any ideas on how to fix it?
Despite what some moderators and others have said, the original Detector Tools works fine updating the Max 360 with either the Defender database or the firmware. At least it does on my Windows 7 computer.
Reply With Quote
  #5  
Old June 12th, 2019
kconwell kconwell is offline
Junior Member
 
Join Date: Jun 2019
Posts: 2
Default

Quote:
Originally Posted by ThomThom View Post
Despite what some moderators and others have said, the original Detector Tools works fine updating the Max 360 with either the Defender database or the firmware. At least it does on my Windows 7 computer.
The original detector tools does not work with my Max 360 and Windows 10 build 1903. After doing some more research on errors like this, I'm starting to believe that it's on Escort's end, specifically one (or more) server certificates have either expired or the webhost is failing to respond. This is an SSL/TLS security issue, which is handled by the server that the Detector Tools tries to phone home/connect with.
Reply With Quote
  #6  
Old June 12th, 2019
thewalkingdr3ad thewalkingdr3ad is offline
Junior Member
 
Join Date: Jun 2019
Posts: 4
Exclamation Resolved

So this issue was on their end and it was the SSL that had expired. I called them earlier and they said that an email was sent out to the staff this morning saying that call volumes would be higher, but the issue was fixed around 12pm CST today.

Checked with my radar, and I am able to update without issue. Didn't fix the sound issue that I have so ordered a damn speaker as well!
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 11:19 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.