Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > ESCORT iX

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old June 2nd, 2018
Not Sure Not Sure is offline
Junior Member
 
Join Date: Jun 2018
Posts: 2
Default No Sound

Hello,

I just purchased an Escort IX today and there is no sound coming from the speakers. I plugged in an AUX cord and I could hear all of the alerts, but I hope that I don't have to do that every time. Is this normal? Thanks!
Reply With Quote
  #2  
Old June 4th, 2018
Not Sure Not Sure is offline
Junior Member
 
Join Date: Jun 2018
Posts: 2
Default

Ok, guess Iíll be taking back to Best Buy to exchange for a new one.
Reply With Quote
  #3  
Old June 5th, 2018
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,387
Default

I'm sorry to hear this. It will need to be replaced or repaired.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 06:53 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © 2018 Escort Inc.