Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > MAX 360c

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old January 6th, 2019
SandmanXXX SandmanXXX is offline
Junior Member
 
Join Date: Jan 2019
Posts: 1
Default Brand new Max360c from Bestbuy lockup :(

I bought a Max360c today, 1/6/19, serial 1a21xxxx, from BestBuy. Drove with it on, out of the box, and mounted, all the way home. Did not connect anything except the power cable. On a 27 mile trip, about 35ish minutes total, at around the 25 minute mark I noticed it had the solid SL sign at 70 OSP, while I was on a 55 mph road. Now, from about 5 minutes out of BB until the 20 minute mark I was on I85 in NC, which showed up as 70mph in the display. All the rest of the way home it stayed that way. So essentially, it locked up on me, basically froze, although the moving bars were still moving with AUTO in the middle of the display. I never had any alerts during the guesstimated lockup time, for the rest of the trip, but it's unknown if I actually had any.

And MAN does it get pretty warm to the touch after a few minutes of running.
Going to try and watch it a few days to see if it does it again, but now my confidence in the unit is a little shaken.

I did not get a video of it, as I did not expect this to happen. With only owning it a few hours, I have since gotten it connected to the Escort Live app for android, and gotten Bluetooth connected to my phone. This connecting was done in my driveway after getting home. Had to restart the RD, as 70mph in my driveway wouldn't work

One other weird thing that seems to happen, recreate-able, when I connect via Bluetooth to my phone, a Pixel 3 XL, and then go into the Escort Live app, the app says nothing connected. So I hit the upper right icon to connect it, via Bluetooth, and it connects to the Live app, but then it loses BT connection to the phone. Starting over, I have to forget the 360c in the pixel BT menu, find it and connect to it, then run the app, then connect it in the app. I did this 6 times in a row, with number 6 happening an hour later after I disconnected everything and went into the house, and brough the max360c inside the house as well.
The car is a 2015 Chevrolet Cruze.
Is this expected behavior ?
Thanks.

Last edited by SandmanXXX; January 6th, 2019 at 08:30 PM.
Reply With Quote
  #2  
Old January 6th, 2019
ckelly33 ckelly33 is offline
Junior Member
 
Join Date: Nov 2017
Posts: 5
Default

I've had one this summer and I have used it ALMOST everyday. Admittedly, most of my driving is less than 20 minutes. When I have driven in longer trips, I haven't had any issues ( other than the one)

Were you on current firmware?

Sent from my SM-T830 using Tapatalk
Reply With Quote
  #3  
Old January 8th, 2019
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,703
Default

It is normal for our detectors to display "70 OSP" on the leftmost area of the display. This is the OverSpeed alert setting which can be changed, or disabled.

When you connect the detector to Escort Live or Wi-Fi with a premium Escort Live subscription, then this area will be replaced with the speed limit of the road you are on, if speed limit data is available for that road.
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #4  
Old January 11th, 2019
wanderer1 wanderer1 is offline
Member
 
Join Date: Aug 2018
Location: American living in Flor-i-DAH
Posts: 59
Default

I'am curious ER, what would it display in the OSP space when not on Escort Live & overspeed alert was turned off?
__________________
Tried almost all brands of detectors over the years, ESCORT won. Have owned original CM Escort w/mute, original Passport, Escort DSP (all time favorite, metal case, key, unreal range), Solo 5 battery pwr (I think), Passport 7500 (crap KA), Passport 8500 (better KA), Passport 8500 X50 (best KA), Passport X80 (not too bad), Escort IX (solidly built, really liked it but falsed a little too much) and currently a Max 360 BLE v 1.7

DRIVE SMARTER OR GET THE HELL OUTTA THE LEFT LANE
Reply With Quote
  #5  
Old January 15th, 2019
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 16,703
Default

With Over Speed off, dashes are displayed instead of a numerical value
__________________

Escort Radar customer service is available from 9am-5:30pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #6  
Old February 1st, 2019
wanderer1 wanderer1 is offline
Member
 
Join Date: Aug 2018
Location: American living in Flor-i-DAH
Posts: 59
Default

Ok, ER thanks for the reply.
__________________
Tried almost all brands of detectors over the years, ESCORT won. Have owned original CM Escort w/mute, original Passport, Escort DSP (all time favorite, metal case, key, unreal range), Solo 5 battery pwr (I think), Passport 7500 (crap KA), Passport 8500 (better KA), Passport 8500 X50 (best KA), Passport X80 (not too bad), Escort IX (solidly built, really liked it but falsed a little too much) and currently a Max 360 BLE v 1.7

DRIVE SMARTER OR GET THE HELL OUTTA THE LEFT LANE
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 07:42 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.