Escort Radar Forum  

Go Back   Escort Radar Forum > Escort Live! > Escort Live! for iPhone

Notices

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old July 27th, 2020
Pocono78 Pocono78 is offline
Junior Member
 
Join Date: Jul 2020
Posts: 3
Default Escort Live, 9500ix, iOS not working

I have an Escort 9500ix (S/N 331402913914) and SmartCord Live (S/N 69001127) that used to work. Now, with the latest version of the iOS Escort Live app installed on my iPhone, I am unable to see the SmartCord/radar detector even when I've enable bluetooth connectivity. Any suggestions?
Reply With Quote
  #2  
Old July 27th, 2020
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Moderator
 
Join Date: Apr 2019
Location: USA
Posts: 1,666
Default

Quote:
Originally Posted by Pocono78 View Post
I have an Escort 9500ix (S/N 331402913914) and SmartCord Live (S/N 69001127) that used to work. Now, with the latest version of the iOS Escort Live app installed on my iPhone, I am unable to see the SmartCord/radar detector even when I've enable bluetooth connectivity. Any suggestions?
Go into your ipohone bluetooth and find the cord/detecotor and "forget" it.

Restart detector and phone and smart cord, and then go into the Live app and go to settings - devices. See if the smart cord appears in the device list. If so pair to it.

Let me know.
__________________
I use the following Escort Products

Escort Redline 360c
M1 Dash cam
Escort Live
-----------------------------------------------------------
If you need immediate help please contact Escort Customer service by calling 1-800-543-1608, option 2. , M-F 9:00AM-5:30PM EST..
------------------------------------------------------------
To contact an Official Escort Representative/Forum Admin please use this link below.

http://escortradarforum.com/forums/sendmessage.php
Reply With Quote
  #3  
Old July 28th, 2020
Pocono78 Pocono78 is offline
Junior Member
 
Join Date: Jul 2020
Posts: 3
Default

Yes, I've done that--the SmartCord isn't even visible in the device list.
Reply With Quote
  #4  
Old July 28th, 2020
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,811
Default

It sounds to me that your EL SmartCord has failed.

I also have a 9500ix and an EL SmartCord, and it works fine using my iPhone 6s with iOS v13.5.1.
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
Dashcam: Escort M1 and Thinkware F750

-------------------------------------
Moderators here are not Escort employees.
If you need immediate help, please call Escort Radar customer service at 1-800-543-1608, option 2, available from 9am-5:30pm Eastern Time Mon-Fri.
-------------------------------------
Reply With Quote
  #5  
Old July 28th, 2020
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Moderator
 
Join Date: Apr 2019
Location: USA
Posts: 1,666
Default

I think you need a new smartcord, or even better , an upgrade to your detector.
__________________
I use the following Escort Products

Escort Redline 360c
M1 Dash cam
Escort Live
-----------------------------------------------------------
If you need immediate help please contact Escort Customer service by calling 1-800-543-1608, option 2. , M-F 9:00AM-5:30PM EST..
------------------------------------------------------------
To contact an Official Escort Representative/Forum Admin please use this link below.

http://escortradarforum.com/forums/sendmessage.php
Reply With Quote
  #6  
Old July 28th, 2020
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,811
Default

Quote:
Originally Posted by Esc0rtFan View Post
I think you need a new smartcord, or even better , an upgrade to your detector.
I concur. The 9500ix was the best of the best in its day, but as CAS/BSM car systems became commonplace, my 9500ix was giving me lots of false alerts, so I retired it.

If I would make a recommendation, it would be to consider getting a more up-to-date Escort detector, and use your 9500ix as a trade-in. That's what I've done.

Best wishes!
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
Dashcam: Escort M1 and Thinkware F750

-------------------------------------
Moderators here are not Escort employees.
If you need immediate help, please call Escort Radar customer service at 1-800-543-1608, option 2, available from 9am-5:30pm Eastern Time Mon-Fri.
-------------------------------------

Last edited by TBNTX; July 28th, 2020 at 09:39 PM.
Reply With Quote
  #7  
Old August 13th, 2020
Pocono78 Pocono78 is offline
Junior Member
 
Join Date: Jul 2020
Posts: 3
Default

I purchased a new SmartCord Live. iPhone has version 3.1.27 installed. The LED turns blue on the SmartCord indicating Bluetooth connection, however it doesn't see my 9500ix. In addition, while it shows that it is connected in the iPhone's Bluetooth list, the dashboard of the app shows the Bluetooth symbol blinking with the message that it is still connecting. Does it just take a long time for the connection to occur and that's why the 9500ix isn't listed?
Reply With Quote
  #8  
Old August 13th, 2020
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Moderator
 
Join Date: Apr 2019
Location: USA
Posts: 1,666
Default

Quote:
Originally Posted by Pocono78 View Post
I purchased a new SmartCord Live. iPhone has version 3.1.27 installed. The LED turns blue on the SmartCord indicating Bluetooth connection, however it doesn't see my 9500ix. In addition, while it shows that it is connected in the iPhone's Bluetooth list, the dashboard of the app shows the Bluetooth symbol blinking with the message that it is still connecting. Does it just take a long time for the connection to occur and that's why the 9500ix isn't listed?
I will leave this one for TBNTX. He has been a 9500ix user for many years and is very experienced with this setup... He will probably see this very soon.
__________________
I use the following Escort Products

Escort Redline 360c
M1 Dash cam
Escort Live
-----------------------------------------------------------
If you need immediate help please contact Escort Customer service by calling 1-800-543-1608, option 2. , M-F 9:00AM-5:30PM EST..
------------------------------------------------------------
To contact an Official Escort Representative/Forum Admin please use this link below.

http://escortradarforum.com/forums/sendmessage.php
Reply With Quote
  #9  
Old August 13th, 2020
TBNTX's Avatar
TBNTX TBNTX is offline
Moderator
 
Join Date: Mar 2012
Location: Topeka, KS
Posts: 6,811
Default

Quote:
Originally Posted by Esc0rtFan View Post
I will leave this one for TBNTX. He has been a 9500ix user for many years and is very experienced with this setup... He will probably see this very soon.
There have been several versions of the EL Smartcord over the years, but since you have the latest one, Pocono78, what version of Escort Live are you using? I ask this with a purpose.

In the early days, users had to bind their BT connection from within the iPhone's BT Preferences menu. Later on, the users had to bind the connection thru the EL app's settings menu. I had to do the same, myself.

Say more. We're all here to help.

TBNTX
__________________


Countermeasures:

Radar Detectors: Max 360c, Redline EX, Max 360, & others plus Escort Live!
Dashcam: Escort M1 and Thinkware F750

-------------------------------------
Moderators here are not Escort employees.
If you need immediate help, please call Escort Radar customer service at 1-800-543-1608, option 2, available from 9am-5:30pm Eastern Time Mon-Fri.
-------------------------------------
Reply With Quote
  #10  
Old August 13th, 2020
Esc0rtFan's Avatar
Esc0rtFan Esc0rtFan is offline
Moderator
 
Join Date: Apr 2019
Location: USA
Posts: 1,666
Default

Quote:
Originally Posted by TBNTX View Post
There have been several versions of the EL Smartcord over the years, but since you have the latest one, Pocono78, what version of Escort Live are you using? I ask this with a purpose.

In the early days, users had to bind their BT connection from within the iPhone's BT Preferences menu. Later on, the users had to bind the connection thru the EL app's settings menu. I had to do the same, myself.

Say more. We're all here to help.

TBNTX
Thanks TBNTX!!
__________________
I use the following Escort Products

Escort Redline 360c
M1 Dash cam
Escort Live
-----------------------------------------------------------
If you need immediate help please contact Escort Customer service by calling 1-800-543-1608, option 2. , M-F 9:00AM-5:30PM EST..
------------------------------------------------------------
To contact an Official Escort Representative/Forum Admin please use this link below.

http://escortradarforum.com/forums/sendmessage.php
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:46 AM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright 2018 Escort Inc.