Escort Radar Forum  

Go Back   Escort Radar Forum > Installed Detector Systems > Passport 9500ci

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old May 2nd, 2012
Ajackfish Ajackfish is offline
Member
 
Join Date: Oct 2009
Posts: 56
Default Is my 9500ci working?

I have seen this question asked several times, but I don't have a good answer to my question. The system was installed in my car approximately 3 + years ago and I update it frequently. Every once in a while it will tell me to check wiring, but the alert goes away very soon. Today I drove approximately 70 miles to a city I hadn't gone to before in this car. I had two laser alerts, but no radar alerts. I drove by two police vehicles parked on the edge of the road with no alerts and several shopping centers & gas stations with automatic doors. Is my system working??
Reply With Quote
  #2  
Old May 2nd, 2012
Dashcam347's Avatar
Dashcam347 Dashcam347 is offline
Senior Member
 
Join Date: Feb 2012
Posts: 278
Default

Quote:
Originally Posted by Ajackfish View Post
I have seen this question asked several times, but I don't have a good answer to my question. The system was installed in my car approximately 3 + years ago and I update it frequently. Every once in a while it will tell me to check wiring, but the alert goes away very soon. Today I drove approximately 70 miles to a city I hadn't gone to before in this car. I had two laser alerts, but no radar alerts. I drove by two police vehicles parked on the edge of the road with no alerts and several shopping centers & gas stations with automatic doors. Is my system working??
Make sure that all the bands are enabled. If they are, I would be worried, even more with that check wiring thing. What mode are you running?
Reply With Quote
  #3  
Old May 3rd, 2012
Ajackfish Ajackfish is offline
Member
 
Join Date: Oct 2009
Posts: 56
Default

Within the last two weeks I have heard X, K & Ka. I run in auto mode. I just leave it there.
Reply With Quote
  #4  
Old May 3rd, 2012
Dashcam347's Avatar
Dashcam347 Dashcam347 is offline
Senior Member
 
Join Date: Feb 2012
Posts: 278
Default

Put it on highway just to try it out. I see a hell of a difference in town between highway and City
Reply With Quote
  #5  
Old May 4th, 2012
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 11,404
Default

Also when testing radar detection, turn off GPS so that it detects all falses. If you don't receive these alerts then I recommend sending it in. You shouldn't see the "check rcvr wiring" unless there is a problem, which ironically enough may not be an issue with the wiring.
__________________

Escort Radar customer service is available from 9am-4pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #6  
Old May 4th, 2012
Ajackfish Ajackfish is offline
Member
 
Join Date: Oct 2009
Posts: 56
Default

THANKS, It makes sense. Jack
Reply With Quote
  #7  
Old May 6th, 2012
Ajackfish Ajackfish is offline
Member
 
Join Date: Oct 2009
Posts: 56
Default

I have turned off the GPS and I get NO alerts. I plan to check the contacts and if there is nothing still, I will call to send in for repairs.
Reply With Quote
  #8  
Old May 15th, 2012
Ajackfish Ajackfish is offline
Member
 
Join Date: Oct 2009
Posts: 56
Default

This system is irratic. Today coming into work my detector is hitting on 'x' band from the school buses. Yesterday, it did not. Taking it out for repair is a major hassle. Any suggestions??
Reply With Quote
  #9  
Old May 15th, 2012
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 11,404
Default

It will probably need to be sent in if you are seeing an error message and the connections are good.
__________________

Escort Radar customer service is available from 9am-4pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #10  
Old May 16th, 2012
Ajackfish Ajackfish is offline
Member
 
Join Date: Oct 2009
Posts: 56
Default

As soon as I can get it out, it goes in.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:28 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2012 Escort Inc.