Escort Radar Forum  

Go Back   Escort Radar Forum > Windshield Radar Detectors > Passport 9500ix

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old April 12th, 2012
Jesse_w_k Jesse_w_k is offline
Senior Member
 
Join Date: Oct 2011
Location: Virginia
Posts: 412
Default 9500ix Redlight camera accuracy

So my 9500ix, with a serial number 19 has since I can remember warned me of some red light cameras before I reach them (as it should) while it notifies me of others once I have already passed through the intersection. It seems that the accuracy of the 9500ix knowing where I am/direction of travel is very flaky.

I can go through the same intersection 4 different ways and I will get 4 different results. However, I get the exact same reaction no matter how many times I go through the same way, if that made sense. I figured that the data of where the cameras were was inaccurate until I started using Escort Live! When I approach any intersection, Live! is always spot on, knows exactly where I'm going and how far the camera is in front of me. Also, in one scenario if I take a right turn (bypassing the intersection completely) my 9500ix tells me about the red light camera after I have completed the turn to the next road and am traveling away from the camera.

This has had me questioning my 9500ix, as the data for the cameras is obviously valid, but my 9500ix is not able to react the same way as Live!....

Is there a reason for this?
I was thinking maybe the calibration was off?... I also feel like I've recently been receiving more falses than normal (in the past 6 months).

The camera issue has been probably for the past 2 years that the cameras have been there.

I've seen some other threads where people have had other inconsistent issues, but mine happens every time the exact same way.
Reply With Quote
  #2  
Old April 13th, 2012
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 11,167
Default

Does the top of your 9500ix have a clear view of the sky? A poor GPS signal can cause these issues.
__________________

Escort Radar customer service is available from 8am-6pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #3  
Old April 13th, 2012
Jesse_w_k Jesse_w_k is offline
Senior Member
 
Join Date: Oct 2011
Location: Virginia
Posts: 412
Default

Quote:
Originally Posted by EscortRadar View Post
Does the top of your 9500ix have a clear view of the sky? A poor GPS signal can cause these issues.
Yea it has a clear view of the sky. It does this in my truck and my car. Has the exact same response regardless of when I had it lower (farther out) or higher up like I have it now under my RVM. The GPS signal locks in quickly no problems and have not noticed any difference between vehicles.

For what it's worth my phone is farther inward (on my vent) of my vehicles and it has the grey dot (poor signal) while using Live! and it still acts exactly as it should. BTW I have also concluded that I don't think the grey dot can be from poor GPS signal (in my case) because I've stood in the bed of my truck with my phone out on a nice clear day and the dot was still grey...possibly a specific issue with my phone. Live! seems to act fine even with the grey dot.
Reply With Quote
  #4  
Old April 16th, 2012
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 11,167
Default

I'm not sure why your 9500ix would alert to cameras after you passed them when traveling straight through the intersection.

Alerting when turning at an intersection is normal. This is because a camera is at the intersecting road and when you turn you briefly enter the alert angle window for that camera.

If this erratic GPS location alerting behavior is consistent on your 9500ix then we may need to service it. Please contact our service department at the number in my signature below.
__________________

Escort Radar customer service is available from 8am-6pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #5  
Old April 18th, 2012
Eric_w's Avatar
Eric_w Eric_w is offline
Member
 
Join Date: Jun 2011
Location: Daytona Beach area
Posts: 46
Default

I have the same issue. I don't get a warning until at one red light camera. 100 feet or so past the intersection I get :you have reached....:

I emailed the problem and all that was done was to remove a red light warning, that worked well, at that same intersection on a street that intersects at a 90 degree angle.

There are three red light cameras in close proximity. Could that be an issue?
Reply With Quote
  #6  
Old April 18th, 2012
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 11,167
Default

Quote:
Originally Posted by Eric_w View Post
There are three red light cameras in close proximity. Could that be an issue?
Please send me a private message with these camera locations (both streets, city and state)
__________________

Escort Radar customer service is available from 8am-6pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #7  
Old April 18th, 2012
Jesse_w_k Jesse_w_k is offline
Senior Member
 
Join Date: Oct 2011
Location: Virginia
Posts: 412
Default

Quote:
Originally Posted by Eric_w View Post
I have the same issue. I don't get a warning until at one red light camera. 100 feet or so past the intersection I get :you have reached....:

I emailed the problem and all that was done was to remove a red light warning, that worked well, at that same intersection on a street that intersects at a 90 degree angle.

There are three red light cameras in close proximity. Could that be an issue?
What do u mean? Just turn off red light camera information all-together? This doesn't sound like much of a solution...

And no, this is the only camera for like a mile or more.
Reply With Quote
  #8  
Old April 18th, 2012
Eric_w's Avatar
Eric_w Eric_w is offline
Member
 
Join Date: Jun 2011
Location: Daytona Beach area
Posts: 46
Default

Quote:
Originally Posted by Jesse_w_k View Post
What do u mean? Just turn off red light camera information all-together? This doesn't sound like much of a solution...

And no, this is the only camera for like a mile or more.
I was writing about having the same issue as you. Read it again.

Eric
Reply With Quote
  #9  
Old April 19th, 2012
EscortRadar's Avatar
EscortRadar EscortRadar is offline
Official Escort Rep
 
Join Date: Apr 2009
Posts: 11,167
Default

Quote:
Originally Posted by Eric_w View Post
I emailed the problem and all that was done was to remove a red light warning, that worked well, at that same intersection on a street that intersects at a 90 degree angle.

There are three red light cameras in close proximity. Could that be an issue?
The intersection that you gave me is only enforced in one direction, southbound. Try removing the northbound camera manually by pressing the mark button while receiving the alert going north through the intersection. If it returns after you update Defender again then please let me know.

Many intersections have cameras in all directions to take video and pictures of the rear of offending vehicles.
__________________

Escort Radar customer service is available from 8am-6pm Eastern Time Mon-Fri at 1-800-543-1608 or by live chat
Reply With Quote
  #10  
Old April 25th, 2012
Patrick S Patrick S is offline
Junior Member
 
Join Date: Apr 2012
Posts: 6
Default Cameras not at a location that is marked

I have three intersections marked as having cameras in close proximity to my home, but only two of them actually have cameras. It's not a proximity situation (where I'm getting alerted about a nearby camera) because it's about 1/4 mile away and I get alerted appropriately for the actual camera. How can I get the non-camera site removed?

http://screencast.com/t/zjXiPgBgrK
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 09:41 PM.


Powered by vBulletin® Version 3.8.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 2012 Escort Inc.